Blog‎ > ‎

SECOND LIFE JOYSTICK THROTTLE FIX

posted Jan 19, 2017, 9:51 PM by Braclo Neff   [ updated Jan 28, 2017, 11:23 PM ]
Originally posted May 29, 2014

https://www.flickr.com/photos/braclo/11674859125/in/dateposted/


This is a copy of my guide posted on my previous blog over at blogspot.

Greetings all,

After looking for a fix for some time now, I have finally found the solution to an issue that have been affecting some people, including myself, for a while now in Second Life.
When using a joystick to control the camera or your avatar in Second Life, some joystick’s throttle control is not recognized.

How many joysticks are affected by this I do not know, but I can confirm the Logitech Extreme 3D Pro is one. I can also confirm not all joysticks are affected by this as I had some cheap joystick in the past that worked fine.

The answer?
vJoy + UJR

What is vJoy?
“vJoy is a device driver that bridges the gap between any device that is not a joystick and an application that requires a joystick. If you develop an application for windows that requires user physical input you should consider incorporating vJoy into your product.”

What is UJR?
“UJR is an application to remap one or more physical joysticks onto one virtual joystick.
It supports axis inversion, deadzones, sensitivity, axis merging and more.”

Below is instructions on what to do.
(1) Plug in your Joystick.
(4) In UJR, under the “Bindings” tab, set all the keys.
(5) In UJR, under the “Buttons 1” tab, bottom right, select “Auto Configure Stick“.
(6) In UJR, under the “Axes 1” tab, bottom right, select “Auto Configure Stick“.
(7) Now open Second Life under the joystick settings, it should show it is using vJoy Device.

Now below is the settings I have setup for UJR and Second Life since the Auto Configure settings binded some axis I do not use.

UJR Settings

Second Life Settings

When I finished setting everything up, I realized that the #1 button on my joystick do not register in Second Life to activate the Flycam, which it should based on the settings under the “Button 1″ tab.

To fix this:
-I activate “QuickBind Select” binding I setup in step (4);
-I pressed the #1 joystick button;
-I activate “QuickBind” binding I setup in step (4);
-I pressed the #1 joystick button;
After that it worked fine, although I am not sure why (5) did not work the first place.

Hopefully this works for everyone, but if you have trouble, feel free to comment below or on the forum topics I have posted this and I will try and help as best I can
-Braclo
Comments